За последние 24 часа нас посетили 12723 программиста и 711 роботов. Сейчас ищут 448 программистов ...

IDEA не видит xdebug.

Тема в разделе "IDE", создана пользователем DarkGuy, 19 мар 2017.

  1. DarkGuy

    DarkGuy Активный пользователь

    С нами с:
    9 янв 2011
    Сообщения:
    40
    Симпатии:
    0
    Добрый день!

    На машине Debian установлен IDEA, машина в той же сети что и сервер. IDEA не видит xdebug. Как исправить?


    С работы могу присоединиться к серверу дома. Все ок. xdebug работает как часы.
    Из дома не работает.
    Выдает
    Код (Text):
    1.  
    2. waiting for incoming connection with ide key
    Настройки в Средах дома и на работе одинаковые.

    Настройки сервера
    uname -a
    Код (Text):
    1.  
    2. Linux HomeMiniServer 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
    nano /etc/php5/apache2/php.ini
    Код (Text):
    1.  
    2. ...
    3. zend_extension=xdebug.so
    4. xdebug.remote_host=92.121.61.47
    5. xdebug.remote_enable=1
    6. xdebug.remote_connect_back=1
    7. xdebug.idekey=HomeMiniServerKey
    8. xdebug.remote_port=9009
    9. xdebug.remote_handler=dbgp
    10. xdebug.remote_autostart=1
    11. xdebug.profiler_enable=1;
    12. xdebug.profiler_output_dir="/var/www/profiler"
    13. xdebug.profiler_enable_trigger=1
    nano /etc/php5/conf.d/20-xdebug.ini пусто

    настройки в домашней машине и IDEA
    uname -a
    Код (Text):
    1.  
    2. Linux HOME-PCL 4.9.0-1-amd64 #1 SMP Debian 4.9.6-3 (2017-01-28) x86_64 GNU/Linux
    iptables -L -n -v
    Код (Text):
    1.  
    2. Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
    3.  pkts bytes target     prot opt in     out     source               destination        
    4.  
    5. Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    6.  pkts bytes target     prot opt in     out     source               destination        
    7.  
    8. Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
    9.  pkts bytes target     prot opt in     out     source               destination    
    netstat -tnlp
    Код (Text):
    1.  
    2. Active Internet connections (only servers)
    3. Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
    4. tcp        0      0 127.0.0.1:63342         0.0.0.0:*               LISTEN      1961/java          
    5. tcp        0      0 0.0.0.0:20080           0.0.0.0:*               LISTEN      1961/java          
    6. tcp        0      0 0.0.0.0:9009            0.0.0.0:*               LISTEN      1961/java          
    7. tcp        0      0 127.0.0.1:5939          0.0.0.0:*               LISTEN      848/teamviewerd    
    8. tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      409/cupsd          
    9. tcp        0      0 0.0.0.0:10137           0.0.0.0:*               LISTEN      1961/java          
    10. tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1080/exim4          
    11. tcp        0      0 127.0.0.1:9050          0.0.0.0:*               LISTEN      645/tor            
    12. tcp        0      0 127.0.0.1:6942          0.0.0.0:*               LISTEN      1961/java          
    13. tcp        0      0 127.0.0.1:58846         0.0.0.0:*               LISTEN      1827/python        
    14. tcp        0      0 0.0.0.0:58433           0.0.0.0:*               LISTEN      1827/python        
    15. tcp6       0      0 :::80                   :::*                    LISTEN      649/apache2        
    16. tcp6       0      0 ::1:631                 :::*                    LISTEN      409/cupsd          
    17. tcp6       0      0 ::1:25                  :::*                    LISTEN      1080/exim4          
    18. tcp6       0      0 :::58433                :::*                    LISTEN      1827/python  
    IDEA

    [​IMG]



    [​IMG]



    [​IMG]



    [​IMG]



    [​IMG]



    [​IMG]


    настройки роутера где
    192.168.1.10 сервер
    192.168.1.20 пк


    [​IMG]


    ping и телнет проходит.
    Не могу понять почему не срабатывает xdebug?
     
  2. igordata

    igordata Суперстар
    Команда форума Модератор

    С нами с:
    18 мар 2010
    Сообщения:
    32.415
    Симпатии:
    1.767
    Remote host не нужен, если и так стоит connect back. Проверь маппинг, обычно в нем косяк, посмотри лог IDE, там может быть ченить. У тебя вообще не видно ничего в маппинге, который на одном из скринов

    Порт стандартный 9000 кажется
     
  3. DarkGuy

    DarkGuy Активный пользователь

    С нами с:
    9 янв 2011
    Сообщения:
    40
    Симпатии:
    0
    Марина сверял , настройки аналогичны дома и на работе. Он просто свернут. По 9000 результат такой же.
     
  4. DarkGuy

    DarkGuy Активный пользователь

    С нами с:
    9 янв 2011
    Сообщения:
    40
    Симпатии:
    0
    В логах пусто
     
  5. igordata

    igordata Суперстар
    Команда форума Модератор

    С нами с:
    18 мар 2010
    Сообщения:
    32.415
    Симпатии:
    1.767
    ищи. там либо есть коннект, либо нету. либо маппинг работает, либо нет. Всё.