За последние 24 часа нас посетили 6609 программистов и 529 роботов. Сейчас ищут 211 программистов ...

Не получается переключить версию php с 7

Тема в разделе "Установка PHP", создана пользователем sergej_savelev, 29 апр 2016.

Метки:
  1. sergej_savelev

    sergej_savelev Активный пользователь

    С нами с:
    10 янв 2013
    Сообщения:
    18
    Симпатии:
    1
    Добрый день!

    Необходимо чтобы сайт работал на php 5 версии.
    Тружусь уже второй день, всё перепробовал (что нашёл). Составленная мной статья, которая была вполне рабочей, в моём случае лишняя трата времени.

    Версия системы Ubuntu 16.04, php 7.0.4-7ubuntu4, связка apache + nginx.

    Какие есть варианты?
     
  2. denis01

    denis01 Старожил
    Команда форума Модератор

    С нами с:
    9 дек 2014
    Сообщения:
    12.132
    Симпатии:
    1.677
    Адрес:
    Молдова, г.Кишинёв
  3. sergej_savelev

    sergej_savelev Активный пользователь

    С нами с:
    10 янв 2013
    Сообщения:
    18
    Симпатии:
    1
    Пробовал, не помогло. Вот на этом этапе проблема:

    Код (Text):
    1. apt-get update
    2. W: The repository 'http://ppa.launchpad.net/ondrej/php/ubuntu yakkety Release' does not have a Release file.
    3. N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    4. N: See apt-secure(8) manpage for repository creation and user configuration details.
    5. E: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/yakkety/main/binary-amd64/Packages  404  Not Found
    6. E: Failed to fetch http://ppa.launchpad.net/ondrej/php/ubuntu/dists/yakkety/main/binary-i386/Packages  404  Not Found
    7. E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.
    --- Добавлено ---
    Исправил файл /etc/apt/sources.list.d/ondrej-ubuntu-php-yakkety.list, изменив версию с yakkety на xenial, пошло как по маслу :) Спасибо за внимание!
     
  4. igordata

    igordata Суперстар
    Команда форума Модератор

    С нами с:
    18 мар 2010
    Сообщения:
    32.449
    Симпатии:
    1.738
    а нахрен?
     
  5. denis01

    denis01 Старожил
    Команда форума Модератор

    С нами с:
    9 дек 2014
    Сообщения:
    12.132
    Симпатии:
    1.677
    Адрес:
    Молдова, г.Кишинёв
    Может что-то не завелось с PHP7 вот и делают downgrade
     
  6. igordata

    igordata Суперстар
    Команда форума Модератор

    С нами с:
    18 мар 2010
    Сообщения:
    32.449
    Симпатии:
    1.738
    Если код старый, то он должен работать на пятёрке. Тогда не понятно в чем проблема. Если код новый, то нафик снижаться?
     
  7. mr.akv

    mr.akv Активный пользователь

    С нами с:
    31 мар 2015
    Сообщения:
    1.613
    Симпатии:
    206
    Может написали под 7, а на продакшене куча сайтов под 5?
     
  8. Ganzal

    Ganzal Суперстар
    Команда форума Модератор

    С нами с:
    15 мар 2007
    Сообщения:
    9.799
    Симпатии:
    937
    @mr.akv с fpm такой проблемы нет. просто указываешь nginx-у корректный апстрим и усё.
     
  9. sergej_savelev

    sergej_savelev Активный пользователь

    С нами с:
    10 янв 2013
    Сообщения:
    18
    Симпатии:
    1
    Да я заколебался уже, с этим дурацким обновлением до 16.10 версии ubuntu видимо всё на свете стало современным, один я остался древним как мир. Вот это откуда могло взяться?:
    Код (Text):
    1. Execution of a query to the database failed - Expression #1 of ORDER BY clause is not in GROUP BY clause and contains nonaggregated column 'test.dltv_intop_1.value' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
    Почему в 5 версии перестало работать xml расширение:
    Код (Text):
    1. Failed to load PHP's XML Extension.
    При том что в 7 работает.