За последние 24 часа нас посетили 8499 программистов и 449 роботов. Сейчас ищут 120 программистов ...

откат версий laravel

Тема в разделе "Laravel", создана пользователем selivanov, 21 апр 2017.

  1. selivanov

    selivanov Новичок

    С нами с:
    1 фев 2017
    Сообщения:
    72
    Симпатии:
    3
    я установил версию ларавел 5.4 но я учу по версий 5.2
    можно ли сделать откакт обратно на 5.2
     
  2. Zuldek

    Zuldek Активный пользователь

    С нами с:
    13 май 2014
    Сообщения:
    1.636
    Симпатии:
    126
    Адрес:
    Лондон, Тисовая улица, дом 4, чулан под лестницей
    удали каталог vendor в композере, пропиши нужную версию ларавеля в composer.json и дерни composer install. Всё установит.
     
    mahmuzar нравится это.
  3. selivanov

    selivanov Новичок

    С нами с:
    1 фев 2017
    Сообщения:
    72
    Симпатии:
    3
    я установил на опенсервер .в смысле удалить папку композер я так понял?
     
  4. artoodetoo

    artoodetoo Старожил
    Команда форума Модератор

    С нами с:
    11 июн 2010
    Сообщения:
    7.751
    Симпатии:
    295
    Адрес:
    из России с любовью
    Папку vendor. В неё композер складывает сторонние либы, в т.ч. ларавелевские.

    Фактически эта папка - файловый кеш. Почисти этот "кеш", отредактируй composer.json и попробуй заново заполнить vendor командой "composer install".
    --- Добавлено ---
    Вообще-то наверное лучше начать заново с пустой папки. Просто на этот раз создавай новый проект, явно указывая версию.
    http://stackoverflow.com/q/23754260/272885

    composer create-project laravel/laravel projectName --prefer-dist 5.2
     
    mahmuzar и selivanov нравится это.
  5. selivanov

    selivanov Новичок

    С нами с:
    1 фев 2017
    Сообщения:
    72
    Симпатии:
    3
    спасибо теперь понял .человеческими словами обьяснили