За последние 24 часа нас посетили 7029 программистов и 452 робота. Сейчас ищут 240 программистов ...

Помогите пож.

Тема в разделе "Установка PHP", создана пользователем Ваller, 13 окт 2019.

Метки:
  1. Ваller

    Ваller Новичок

    С нами с:
    13 окт 2019
    Сообщения:
    1
    Симпатии:
    0
    Добрый день, прошу строго не судить, в PHP новичек, но очень нужно решение
    Итак на просторах, гуляет уже написанное приложение https://github.com/bckr75/gibdd
    есть инструкция.. но не могу понять как заставить это все заработать, сижу 3 сутки, нет особо желания вникать с азов, хотя именно их и не хватает, пожалуйста расшифруйте инструкцию по русски..

    скачал php 7.3, скачал composer, Path исправил
    Но в строке cmd ошибка

    PHP:
    1.   [Composer\Exception\NoSslException]
    2.   The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl ex
    3.   tension, you can disable this error, at your own risk, by setting the 'disable-tls' option to true.
    отключить не получается та же ошибка, подскажите с какой стороны подойти, где почитать
    с чего начать

    При команде composer install таже ошибка, хотя раньше выдавало нет библиотеки php-curl-class

    Короче прошу объясните на пальцах, как это запустить
    Заранее спасибо
     

    Вложения:

  2. Roman __construct

    [ БАН ]

    С нами с:
    27 апр 2019
    Сообщения:
    1.273
    Симпатии:
    113
    А вы disable-tls выставили в true как оно вам советует?
     
  3. artoodetoo

    artoodetoo Суперстар
    Команда форума Модератор

    С нами с:
    11 июн 2010
    Сообщения:
    10.265
    Симпатии:
    1.020
    Адрес:
    там-сям
    > The openssl extension is required
    вот что нужно решать.
    Если php собран без поддержки ssl, занчит его можно подключить как расширение.
    Найти в php.ini строчку с подключением расширения ssl и раскомментировать её.
    Код (Text):
    1.  
    2. extension=openssl
    Скорее всего этого будет достаточно.