За последние 24 часа нас посетили 10157 программистов и 1082 робота. Сейчас ищут 154 программиста ...

После обновления php ошибки.

Тема в разделе "PHP для новичков", создана пользователем t4p2, 14 июн 2022.

  1. t4p2

    t4p2 Активный пользователь

    С нами с:
    7 сен 2010
    Сообщения:
    11
    Симпатии:
    0
    Доброго времени суток.
    Произвели обновление на php 7.4 и возникла ошибка по get_magic_quotes_gpc

    В моем случае вот код:
    PHP:
    1. // fix magic quotes
    2.     $_POST = coreFunctions::fixSlashes($_POST);
    3.     $_GET = coreFunctions::fixSlashes($_GET);
    4.     $_REQUEST = coreFunctions::fixSlashes($_REQUEST);
    5.     $_COOKIE = coreFunctions::fixSlashes($_COOKIE);
    6. }
    Ошибка: Deprecated: Function get_magic_quotes_gpc() is deprecated

    Полагаю, что в 7.4 больше не поддерживается эта функция? Можно как-то все-же уговорить работать? )
     
  2. artoodetoo

    artoodetoo Суперстар
    Команда форума Модератор

    С нами с:
    11 июн 2010
    Сообщения:
    10.752
    Симпатии:
    1.150
    Адрес:
    там-сям
    Избавляйтесь от неё, она умерла. Весь процитированный кусок кода убирайте. И видимо все остальные случаи использования этой самописной coreFunctions::fixSlashes()
    --- Добавлено ---
    не нужно )))
     
    t4p2 и [vs] нравится это.