За последние 24 часа нас посетили 5946 программистов и 555 роботов. Сейчас ищут 263 программиста ...

Установка PHP

Тема в разделе "Установка PHP", создана пользователем Александр2, 26 сен 2016.

  1. Александр2

    Александр2 Активный пользователь

    С нами с:
    28 май 2010
    Сообщения:
    4
    Симпатии:
    0
    На локальный компьютер установил PHP 5.4.44 вместе с Apache 2.4.23. Для проверки работоспособности подключил функцию phpinfo(). но там не оказалось списка установленных расширений. В чем может быть моя ошибка?
     
  2. mkramer

    mkramer Суперстар

    С нами с:
    20 июн 2012
    Сообщения:
    6.012
    Симпатии:
    1.099
    Надо в phpinfo расширения раскомментировать
    upload_2016-9-26_15-51-28.png
     
  3. [vs]

    [vs] Суперстар

    С нами с:
    27 сен 2007
    Сообщения:
    10.219
    Симпатии:
    521
    Нужно в выдаче phpinfo() посмотреть директиву "Loaded Configuration File" и сравнить с путем файла, в котором включены расширения.
     
  4. Fell-x27

    Fell-x27 Суперстар
    Команда форума Модератор

    С нами с:
    25 июл 2013
    Сообщения:
    11.983
    Симпатии:
    1.709
    Адрес:
    :сердА
    К делу не совсем относится, но почему 5.4, а не 5.6?
     
  5. Александр2

    Александр2 Активный пользователь

    С нами с:
    28 май 2010
    Сообщения:
    4
    Симпатии:
    0
    В этой директиве написано "none". А как это можно исправить?
    --- Добавлено ---
    У меня стояли старые версии. Сейчас понадобилось перезагрузить ОС, поэтому решил поставить поновее, но не захотел устанавлвать VC11.
    --- Добавлено ---
    Подобный список есть в php.ini. У меня там все, что надо раскомментировано.
     
  6. [vs]

    [vs] Суперстар

    С нами с:
    27 сен 2007
    Сообщения:
    10.219
    Симпатии:
    521
    Добавить директорию с файлом в windows path.
     
  7. Fell-x27

    Fell-x27 Суперстар
    Команда форума Модератор

    С нами с:
    25 июл 2013
    Сообщения:
    11.983
    Симпатии:
    1.709
    Адрес:
    :сердА
    А для этого есть какие-то объективные причины?
     
  8. Александр2

    Александр2 Активный пользователь

    С нами с:
    28 май 2010
    Сообщения:
    4
    Симпатии:
    0
    Спасибо всем откликнувшимся. У меня не работало, скорее всего потому, что не стыковались версии Apache и PHP. Установил VC11, потом соответствующие версии Apache и PHP, и все заработало, как надо.
     
  9. shpashka1986

    shpashka1986 Новичок

    С нами с:
    6 фев 2017
    Сообщения:
    47
    Симпатии:
    1
    Что нужно устанавливать, начиная работать с PHP? Локальный сервер и сам PHP? Или что-то ещё? Я пока пытаюсь начать.
     
  10. miketomlin

    miketomlin Активный пользователь

    С нами с:
    9 авг 2016
    Сообщения:
    932
    Симпатии:
    132
    Да, Web-сервер и PHP. Сервер БД с какой-нибудь оболочкой тоже нужны для хоть сколько-нибудь серьезной работы.
     
  11. shpashka1986

    shpashka1986 Новичок

    С нами с:
    6 фев 2017
    Сообщения:
    47
    Симпатии:
    1
    А здесь пишут про PHPStorm, например. Он заменяет PHP или для чего он нужен?
     
  12. Dimon2x

    Dimon2x Старожил

    С нами с:
    26 фев 2012
    Сообщения:
    1.592
    Симпатии:
    118
    @shpashka1986 это то же самое, что тетрадка для букв
     
  13. shpashka1986

    shpashka1986 Новичок

    С нами с:
    6 фев 2017
    Сообщения:
    47
    Симпатии:
    1
    Ну а чем отличается PHP, скачанный с офсайта, и PHPStorm? И надо ли вообще сам PHP с официального сайта скачивать?
     
  14. mkramer

    mkramer Суперстар

    С нами с:
    20 июн 2012
    Сообщения:
    6.012
    Симпатии:
    1.099
    @shpashka1986, всем. PHPStorm - это IDE (программный комплекс для разработки приложений), а не интерпретатор
     
  15. miketomlin

    miketomlin Активный пользователь

    С нами с:
    9 авг 2016
    Сообщения:
    932
    Симпатии:
    132
    @shpashka1986, на глупые вопросы обязательно отвечать?
     
  16. shpashka1986

    shpashka1986 Новичок

    С нами с:
    6 фев 2017
    Сообщения:
    47
    Симпатии:
    1
    Извините за подобные вопросы, но у меня в этом плане некоторое недопонимание, которое я пытаюсь устранить. По-моему, темой я не ошибся, но лично вы можете не отвечать.
     
    Ash214 нравится это.
  17. Fell-x27

    Fell-x27 Суперстар
    Команда форума Модератор

    С нами с:
    25 июл 2013
    Сообщения:
    11.983
    Симпатии:
    1.709
    Адрес:
    :сердА
    Человек не в теме, но знает, что есть там PHP, увидел какой-то PHPstorm, решил, что это какая-то версия PHP, типа как у винды Win7, Win8, WinVista, WinXP. Это не глупые вопросы, это незнание предмета. И это не позорно и не стыдно и не страшно. Разберется. Не надо самоутверждаться за его счёт.
     
  18. miketomlin

    miketomlin Активный пользователь

    С нами с:
    9 авг 2016
    Сообщения:
    932
    Симпатии:
    132
    И не думал даже. Просто не люблю, когда мучают форумчан вопросами, которые гуглятся за пару сек.